1

Resolved

Which version of Coded UI assemblies(1.0.6 Beta) of CUITe is based on?

description

Hi Experts:
     Could you please tell me which version of Coded UI assemblies the newest version(1.0.6 Beta) of CUITe is based on? I tries to use the newest version of below 4 assemblies with CUITe but failed:
Microsoft.VisualStudio.TestTools.UITest.Common.dll (11.0)
Microsoft.VisualStudio.TestTools.UITest.Extension.dll (11.0)
Microsoft.VisualStudio.TestTools.UITest.Extension.Silverlight.dll (10.0)
Microsoft.VisualStudio.TestTools.UITesting.dll (11.0)

comments

icnocop wrote May 21, 2013 at 6:23 AM

Hi mengya_6,

In the future, please use the Discussions forum for questions; the Issues forum should be used to report bugs and feature requests.

CUITe 1.0.6 Beta has two downloads:
  1. CUITe for .NET v4.5 - this should be used in Visual Studio 2012 for test projects that target .NET 4.5
  2. CUITe for .NET v4 - this should be used in Visual Studio 2010 for test projects that target .NET 4
The latest source code, found in the "Source Code" tab, when built, will contain an additional zip file, "CUITe for .NET v4 (VS2012).zip" which should be used in Visual Studio 2012 for test projects that target .NET 4.

As indicated in the "Documentation" tab, the requirements to use the Coded UI enhanced Framework is as follows:
  1. Visual Studio 2010 Premium or Visual Studio 2010 Ultimate
  2. Visual Studio 2010 Feature Pack 2
If you are still having trouble, please indicate the exact error message(s).

Thank you.

icnocop wrote May 21, 2013 at 6:25 AM

If using Visual Studio 2012, then Visual Studio 2012 Premium or Visual Studio 2012 Ultimate is required.

mengya_6 wrote May 21, 2013 at 9:46 AM

Actually , I've installed ultimate version for VS2010 and VS2012, but it still not work with error : "3 The type or namespace name 'CUITe' could not be found (are you missing a using directive or an assembly reference?)".

I've added the assemblies into reference. Could you please help to confirm what's the version it should be used?

Thanks,
Sophia

mengya_6 wrote May 22, 2013 at 10:03 AM

Could you please response?

icnocop wrote May 22, 2013 at 5:57 PM

Try building and referencing the latest version from the "Source Code" tab.