This project is read-only.

CUITe v 2.0.0 backwards compatible with 1.0.6?

Jan 27, 2016 at 10:47 PM
I currently use version 1.0.6 within my automation. I'm looking into upgrading to version 2.0.0, but I was wondering if there is still support for functions such as Get<T> within 2.0.0? I noticed 2.0.0 uses Find<> instead of Get<T>, but I could not find any information on if Get<T> is contained within 2.0.0.

Any information is appreciated.
Jan 28, 2016 at 12:11 AM
Unfortunately, the Get method was replaced with the Find method in v2.0.

Specifically in https://github.com/icnocop/cuite/commit/428feda329a746108024d0ba9d3d5e27603dcf13

As a workaround, you can create an extension method for example.
Jan 28, 2016 at 4:15 PM
Thank you for the quick response!

Would it be possible to contain both dll's (version 1.0.6 and version 2.0.0) within a project?
Jan 29, 2016 at 12:41 PM
You can try using aliases like this approach:
http://geekswithblogs.net/narent/archive/2008/11/11/126940.aspx

But binding redirects will probably not work.
Apr 14, 2016 at 10:31 PM
See the new wiki page Upgrading from v1.0 to v2.0.