Radiobutton is not getting selected on another machine

Jul 31, 2013 at 1:27 PM
Hi,

I have created a function to select radio button on my UI,when i am running the function on my machine it is working fine radio button is getting selected but when i run it via MTM on test agent machine(another machine) it is not getting selected.

Below is my function
public static string HtmlRadioButton_Select(string strBrowserName, string strObjectDescription)
    {
        //WebLibrary.BrowserSelection();
        CUITe_BrowserWindow pageobj = new CUITe_BrowserWindow(strBrowserName);
        pageobj.SearchProperties[UITestControl.PropertyNames.Name] = strBrowserName;
        pageobj.SetFocus();
        CUITe_HtmlRadioButton RButtonObj = pageobj.Get<CUITe_HtmlRadioButton>(strObjectDescription);

        if (RButtonObj.Exists == true)
        {
            RButtonObj.Select();

            if (pageobj.Popup == true)
            {
                pageobj.PerformDialogAction(BrowserDialogAction.Yes);
            }
            //pageobj.WaitForControlReady();
            strStepStatus = "pass";
            return strStepResultDesc = "Pass - Successfully Selected the RadioButton --" + strObjectDescription;

        }
        else
            strStepStatus = "fail";
        return strStepResultDesc = "Fail - RadioButton with description-- " + strObjectDescription + " does not exists";

    }
Coordinator
Aug 10, 2013 at 11:57 PM
Hi iRohitSharma,

What is the exception and stack trace or the complete error message that you receive?

Does it work with Visual Studio's built-in Coded UI Test Recorder?

What are the differences between your machine and the target test machine? Are they the same Operating System, etc.?

Thank you.