Issue While running in Visual Studio 2010

Aug 7, 2012 at 4:32 AM

Hi ,

I am working with this cuite Framework . I dont have any issues in VS2010. But when I am trying to use the Cuite in Visual Studio 2012 .I am getting an exception 

"System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.VisualStudio.TestTools.UITest.Extension, Version=10.0.0.0, ----"

 

Please let me know the solution for this exception.

Coordinator
Aug 7, 2012 at 8:01 AM

Hi.

Do you have all the pre-requisites installed, as indicated in the Documentation, FAQ, and Quick Start Guide?

1. Visual Studio 2010 Premium or Visual Studio 2010 Ultimate

2. Visual Studio 2010 Feature Pack 2

Thank you.

Aug 8, 2012 at 2:43 PM

Hi

I am getting the Error in Visual Studio 2012 RC, the reason is by default the Coded UI Test Suite of VS2012 is referring to the DLL version 11.0 and Cuite Framework uses the Version 10.0.

Please let me know the procedure to use CUITe Framework in VS2012

Coordinator
Aug 8, 2012 at 6:29 PM

Hi.

Is VS2010 with Feature Pack 2 installed on the same machine as VS2012?

I have not tested CUITe with VS2012 but I'm thinking the easiest way to support it is to rebuild cuite referencing the new dll.

This may require upgrading the solution and projects to VS2012.

Another approach might be to update the appropriate application configuration so that references to the old dll are redirected to use the new dll.

http://msdn.microsoft.com/en-us/library/eftw1fys.aspx

http://blogs.msdn.com/b/thottams/archive/2007/01/30/introduction-to-versioning-and-bindingredirect.aspx

Coordinator
Jan 21, 2013 at 9:44 AM

See work item 1089.

I provided a fix as part of changeset 23703.

Thank you.